gnomon
9 Posts
wrote on 03.03.23 at 10:44
Link to this post
After having installed the stable version of streamWriter again, today (because of the two latest builds of sW were not fully working as expected to me, see also thread https://streamwriter.org/en/forum/faden/1498/), I was faced with streamWriter's question about the database while sW starting anew.

Apparently, I misunderstood this (or this was too cryptic to me); whereas I wanted to save the already existing database, I clicked NO to establish this, only finding that this datebase (within C:\Users\[UserName]\AppData\Roaming\streamWriter) had gone, hence starting sW bottom-up again. The opposite of what I wanted to!

After trying to recover the former database with several programs (and not being able to, I found, but also finding no streamWriter's database entries at all at the searched drive C:, be it recoverable or not, and this was really odd), then this sort of miracle (at least to me) happened: the Everything software on my system was finding (recent) copies of the database (so streamwriter_data.dat that is, though with slightly different names, like streamwriter_data_recovery.dat) at a place totally unexpected to me, and, as far as I know of or remember, not known to any of the programs used for recovery (nor for the recovery itself), but only to myself: J:\verzamelde_dirs\.dat (and never used for sW), so at a drive differing from drive C:. No wonder no entry was found in whatever state by the recovery programs.

I luckily was able to recover the former database now, but in a way really unexpected and as a total miracle to me… Does anyone understand this?
 
alex
2530 Posts
wrote on 06.03.23 at 00:20
Link to this post
Hello,

I'm sorry but I cannot give any support for the latest "stable" version of streamWriter, I can only focus on the newest builds which will become a new (more stable?) stable version.
Can you elaborate on why the newest builds did not work for you? Maybe it's something I can take a look at.
LG/Best regards, Alex

"Journalism is printing what someone else does not want printed. Everything else is public relations."
- George Orwell

D1734FA178BF7D5AE50CB1AD54442494
 
gnomon
9 Posts
wrote on 09.03.23 at 07:19
Link to this post
Hi Alex,

What I found while using the latest builds of your program, was that, while coming back in a running state after having started Windows (11 Pro 22H2) from hibernation, the sound was not. Then, the only way of hearing sW's sound, was closing and starting it another time. Within the latest "stable" version of streamWriter, the sound always came back after hibernation of the system (and is, with this "stable" version running again).

Regards,
gnomon
 
alex
2530 Posts
wrote on 22.03.23 at 16:17
Link to this post
Hi,

I will take a look at it. If there are any news I will post here again.
LG/Best regards, Alex

"Journalism is printing what someone else does not want printed. Everything else is public relations."
- George Orwell

D1734FA178BF7D5AE50CB1AD54442494
 
alex
2530 Posts
wrote on 02.04.23 at 23:33
Link to this post
The problem should be fixed in the latest build.
LG/Best regards, Alex

"Journalism is printing what someone else does not want printed. Everything else is public relations."
- George Orwell

D1734FA178BF7D5AE50CB1AD54442494