Translate streamWriter

The process of translating streamWriter is very easy. It is described here in a few simple steps. If you have any questions, feel free to post in the board.

  • Download Lingus from here. Install it or extract the zip archive. Afterwards launch Lingus.
  • Use Lingus to open streamwriter.exe - it will tell you that two translation projects were found. 'Common' are translations shared across all my applications, so they are seperated from the 'streamWriter' translations. In order to fully translate streamWriter, both 'Common' and 'streamWriter' need to be translated.
  • After opening 'Common' or 'streamWriter', go to 'Project->Project settings...' and add the language you want to translate the application into.
  • Now you can translate every string. While translating, you can use 'File->Save' while the streamwriter.exe you are editing is not running or opened by another application. Doing so you can launch streamWriter after saving to see your current translations in action.
  • After translating both 'Common' and 'streamWriter', save each one to a seperate new file. Do this by using 'File->Save as...' and select 'Lingus Project File' as filetype.
  • Send me a mail with these saved files attached.

Last edited by alex on 09.12.10 at 23:20