Robin Hood
schrieb am 28.08.10 um 17:27 Uhr
Link zu diesem Post
Hallo,

benutze die Version 1.1.0.5 von streamWriter. Aufnehmen klappt problemlos, nur "Stream abspielen" und "Anhören" -> "Stream" (via Kontext-Menü) funktionieren nicht. Da tut sich nichts. Wo könnte das Problem liegen?
 
alex
2464 Beiträge
schrieb am 29.08.10 um 01:05 Uhr
Link zu diesem Post
Hi!

Es passiert wirklich gar nichts? Hm… Welches Betriebssystem und welchen Mediaplayer benutzt du? Vielleicht kann ich die Ursache für das Problem so finden. Wenn ich diese Infos bekomme, gehe ich der Sache auf den Grund. Es wäre schön, wenn du bereit bist, mir da weiter zu helfen:-)

Liebe Grüße
LG/Best regards, Alex

"Journalism is printing what someone else does not want printed. Everything else is public relations."
- George Orwell

D1734FA178BF7D5AE50CB1AD54442494
 
Robin Hood
schrieb am 29.08.10 um 01:20 Uhr
Link zu diesem Post
Also Betriebssystem ist Windows Vista SP2. Mediaplayer ist der integrierte Windows Media Player 11. Hab aber sonst noch nie Internet Radio gehört - außer über Web Interfaces.
 
alex
2464 Beiträge
schrieb am 29.08.10 um 01:53 Uhr
Link zu diesem Post
Hi,

danke für die Infos! Werde die Tage mal schauen, wo das Problem liegen könnte. Falls ich nicht weiter komme, werde ich hier posten.

Ein schönes Restwochenende erstmal noch:-P
LG/Best regards, Alex

"Journalism is printing what someone else does not want printed. Everything else is public relations."
- George Orwell

D1734FA178BF7D5AE50CB1AD54442494
 
alex
2464 Beiträge
schrieb am 29.08.10 um 17:49 Uhr
Link zu diesem Post
Probier es mal mit der neusten Build hier: http://mistake.ws/de/downloads/67/

Damit müsste es klappen. Hoffe ich.
LG/Best regards, Alex

"Journalism is printing what someone else does not want printed. Everything else is public relations."
- George Orwell

D1734FA178BF7D5AE50CB1AD54442494
 
Robin Hood
schrieb am 29.08.10 um 22:18 Uhr
Link zu diesem Post
Danke für die schnellen Antworten. Habe es nun gerade mit dem neuen Build ausprobiert. Nun tut sich was, das ist schon mal gut, es öffent sich der Windows Media Player, ABER dieser stürzt jedes Mal ab. Hab es schon mit verschiedenen Radiostationen/Streams getestet. Immer das gleiche Problem. Folgende Meldung wird angezeigt:

Windows Media Player funktioniert nicht mehr
Windows kann online nach einer Lösung des Problems suchen.

-> Online nach einer Lösung suchen und das Programm schließen
-> Programm schließen

Die online gesuchte Problemlösung hilft nicht und hat - glaube ich - mit dem Problem nichts zu tun.

Unter Problemdetails (welche man im Fehlerfenster via Dropdown-Pfeil anzeigen lassen kann) wird bei mir Folgendes angezeigt:

Problemsignatur:
Problemereignisname: APPCRASH
Anwendungsname: wmplayer.exe
Anwendungsversion: 11.0.6002.18111
Anwendungszeitstempel: 4aa91411
Fehlermodulname: mcspmpeg.ax
Fehlermodulversion: 1.0.0.30
Fehlermodulzeitstempel: 3c767c1a
Ausnahmecode: c0000005
Ausnahmeoffset: 00006652
Betriebsystemversion: 6.0.6002.2.2.0.256.1
Gebietsschema-ID: 1031
Zusatzinformation 1: fd00
Zusatzinformation 2: ea6f5fe8924aaa756324d57f87834160
Zusatzinformation 3: fd00
Zusatzinformation 4: ea6f5fe8924aaa756324d57f87834160

Hilft dir das weiter?
 
alex
2464 Beiträge
schrieb am 29.08.10 um 22:27 Uhr
Link zu diesem Post
Versuch mal folgendes:

Im Streambrowser für einen Stream das Kontextmenü öffnen und dann "Als Playlist speichern…" nehmen. Dann Speicherst du die Liste irgendwo hin (nimm auf jedenfall M3U als Format, sollte standardmäßig gewählt sein, der WMP kommt mit PLS nicht klar), gehst dann mit dem Explorer dahin wo du es gespeichert hast und öffnest die Liste einfach mit einem Doppelklick. Was dann passiert wäre wirklich interessant. Crasht der WMP dann auch, oder spielt er die Playlist ab?
LG/Best regards, Alex

"Journalism is printing what someone else does not want printed. Everything else is public relations."
- George Orwell

D1734FA178BF7D5AE50CB1AD54442494
 
Robin Hood
schrieb am 29.08.10 um 22:32 Uhr
Link zu diesem Post
Hab alles genau nach deiner Anleitung gemacht. Und siehe da - der Radiostream wird problemlos vom Windows Media Player abgespielt, d.h. kein Absturz.
 
alex
2464 Beiträge
schrieb am 30.08.10 um 10:06 Uhr
Link zu diesem Post
Ist an sich natürlich schön - aber ich kann es mir nicht erklären. Weil wenn du im Menü "Stream abspielen" wählst, passiert nichts anderes, als das, was du da per Hand erledigt hast, ausser dass die Datei nach '%TEMP%\streamWriter\playlist.m3u' gespeichert wird. Könntest du vielleicht mal "Stream abspielen" wählen im Streambrowser, und dann schauen, ob die genannte Datei erstellt wurde? Sollte unter Vista ca. so aussehen: C:\Users\DEIN_BENUTZER\AppData\Local\Temp\streamWriter\playlist.m3u wobei AppData glaube ich ein versteckter Ordner ist.
Wäre schön, wenn du das mal nachschauen könntest, irgendwann muss das Problem ja gefunden sein:-)
LG/Best regards, Alex

"Journalism is printing what someone else does not want printed. Everything else is public relations."
- George Orwell

D1734FA178BF7D5AE50CB1AD54442494
 
Robin Hood
schrieb am 30.08.10 um 19:09 Uhr
Link zu diesem Post
Es wird noch mysteriöser. Also ich habe zuvor immer versucht, meine bereits vorausgewählten Radiostationen im linken Fensterbereich anzuhören, d.h. via Kontextmenü "Anhören" -> "Stream". Also ich war nicht in dem eigentlichen Streambrowser-Fenster rechts.

Und komischerweise tritt der Absturz des Windows Media Player nur dann auf, wenn ich "Anhören" -> "Stream" in diesem linken Fenster auswähle, nicht aber, wenn ich im Streambrowser-Fenster bei der gleichen Radiostation via Kontextmenü "Stream abspielen" auswähle.

Ich habe auch nachgeschaut, ob in dem von dir genannten Verzeichnis die Datei playlist.m3u erstellt wird. Ja, das wird sie und zwar in beiden Fällen - sowohl bei der Methode "Anhören" -> "Stream" als auch bei der Methode "Stream abspielen". Der Windows Media Player geht ja auch auf und versucht die Datei zu öffnen, doch aus irgendeinem Grund klappt das nicht und er stürzt ab.

Jetzt habe ich mal die von streamWriter erstellten Dateien playlist.m3u für eine Radiostation verglichen, hier laut.fm/radio-hot100:


a) playlist.m3u, die erstellt wird, wenn ich den Stream über "Stream abspielen" anhöre:

#EXTM3U
#EXTINF:-1,laut.fm/radio-hot100
http://mistake.ws/en/streamdb/getplaylist/list.m3u?id=560


b) playlist.m3u, die erstellt wird, wenn ich den Stream versuche, über "Anhören" -> "Stream" anzuhören:

#EXTM3U
#EXTINF:-1,laut.fm/radio-hot100
http://mistake.ws/en/streamdb/getplaylist/list.pls?id=176


Könnte dieser Unterschied von Bedeutung sein?
 
Robin Hood
schrieb am 30.08.10 um 19:11 Uhr
Link zu diesem Post
Zusätzliche Anmerkung: Das Copy&Paste der playlist.m3u wird hier anders angezeigt als im Text-Editor. Im Text-Editor wird in der dritten Zeile das angezeigt, was hier nur beim Mouse-Over über den Hyperlink http://mistake.ws sichtbar ist.
 
alex
2464 Beiträge
schrieb am 30.08.10 um 20:25 Uhr
Link zu diesem Post
Hi,

vielen Dank erstmal für deine Hilfe bei der Aufklärung des Problems:-)
Und nun direkt zur Erklärung mit Lösung (hoffe ich): Der auffällige Punkt an den Playlists, die du gepostet hast, ist, dass in der zweiten hinten kein list.m3u steht, sondern ein list.pls. Wie schon gesagt, kommt der WMP mit .pls nicht klar. Warum er abschmiert ist ein anderes Thema, hier sagt er nur "Kenne Format nicht". Also habe ich, extra für dich;-), alles, was vom Server an Playlists abgerufen wird, auf M3U umgestellt. Eventuell kann man das irgendwann in den Programmeinstellungen anpassen, wie es einem gefällt. Damit sollte das Problem behoben sein dachte ich mir. Klar, rechts im Browser funktioniert es ja auch. Das jetzige 'Problem' ist allerdings, dass streamWriter sich die benutzten Streams mit allen Daten merkt, inklusive ursprünglicher URL. Das heißt, im Cache war es noch mit der .pls-Playlist, und so wurde dann auch die .pls-Playlist für den WMP genommen, wenn du das Anhören aus der Liste gestartet hast. Du hast jetzt drei Möglichkeiten, aus der Misere zu entkommen.

A) Du löscht die Daten von streamWriter. Das ist eine Datei, die Infos über die Streams links in der Liste beinhaltet, ausserdem die Infos über die Streams oben in der "Addressleiste".

B) Du schnappst dir einen Hex-Editor und änderst in dieser Datei das .pls am Ende der URL in ein .m3u. Weiß nicht ob du das möchtest/dir zutraust, etc.

C) Du bittest mich, im Menü einen Eintrag zu bauen, in der Richtung "Stream restlos entfernen".

Mir wären A oder B am liebsten, weil diese Funktion wohl nicht oft/nie gebraucht wird, denke ich.. Bei der Datei, um die es geht, handelt es sich übrigens um "C:\Users\Benutzername\AppData\Roaming\streamWriter\streamwriter_data.dat"

Ich hoffe das löst das Problem.

Liebe Grüße und noch einen schönen Abend:-P
LG/Best regards, Alex

"Journalism is printing what someone else does not want printed. Everything else is public relations."
- George Orwell

D1734FA178BF7D5AE50CB1AD54442494
 
Robin Hood
schrieb am 30.08.10 um 22:38 Uhr
Link zu diesem Post
Danke für die Problemlösung. Habe mich für Methode A entschieden. Nur war die Datei "streamwriter_data.dat" bei mir nicht in dem von dir angegebenen Verzeichnis, sondern im streamWriter-Programmverzeichnis. Hab sie aber wie gesagt gefunden und nach dem Löschen der Datei und dem neuen Einrichten der Radiostationen/Streams funktioniert alles.

Ebenfalls noch einen schönen Abend.
 
alex
2464 Beiträge
schrieb am 30.08.10 um 22:41 Uhr
Link zu diesem Post
Ah, okay. Dann hast du es im portablen Modus laufen. Jedenfalls sehr schön, dass es jetzt funktioniert:-)
LG/Best regards, Alex

"Journalism is printing what someone else does not want printed. Everything else is public relations."
- George Orwell

D1734FA178BF7D5AE50CB1AD54442494