Acamas
8 Beiträge
schrieb am 20.12.12 um 22:14 Uhr
Link zu diesem Post

Vermutlich ist es KEIN Bug im Code, eher wohl ein falsches Bit im Server??

Priorität: Niedrig (keine Funktionsbeeinträchtigung, max. falsches Ranking)

OS: [W2K - Ist hier wohl irrelevant?]

SW-Build: 434 (nach Wechsel von 433, einen Tag vorher noch 414)

Aufgetreten: seit der Nacht vom 18. zum 19. Dezember (Server-Wechsel?)

Problem: Plötzlich waren alle Streams in meiner Stream-Liste als "bad for recording" markiert (rotes X in der Browser-Liste). Die Streams können zwar problemlos im Stream-Browser über "Set data…" manuell wieder auf "good for recording" zurückgesetzt werden. ABER: Bei Reload der Sender-Liste (Refresh der Chartliste) sind alle roten Kreuzchen wieder da - und zwar (bei mir) reprodizierbar.

Das Zurücksetzen aller (meiner) Streams auf "bad" trotz vorheriger manueller Änderung auf "good" sieht so aus, als ob der Server die Änderungen TROTZ "Connected" bzw. "Verbunden" nicht registriert. (Ohne "Connected" wäre "Set data…" ja auch nicht verfügbar.)

Btw.: Es geht um Sender, die serverseitig (bzw. von der Community) sicherlich nicht alle als "bad" vorgegeben werden, nämlich sämtliche (mp3+aac)-Stationen von Anntenne Bayern sowie noch einige andere Sender.

Zur Nachvollziehbarkeit:

Ich habe ein, zwei Tage nach dem Wechsel von 414 auf 433 und unmittelbar VOR dem Wechsel auf 434 die o.g. Sender aus der Stream-Browser-Liste herausgesucht, in meine individuelle Stream-Liste übernommen und bewertet. Etwas später gab es dann (wie gestern hier geposted) ein paar Probleme mit dem mistake-Login. Das war, als gerade 434 veröffentlicht worden war. Daraufhin habe ich 434 übernommen, wodurch das Login sofort wieder geklappt hat. Erst später, als ich mal die Charts refreshed habe, um mir die veränderten Ladezeiten des Dat-Files anzusehen, habe ich das mit den bad-Kreuzchen gesehen.

Noch ein paar Anmerkungen:

Ich hatte zuvor EINEN der Antenne-Bayern-Sender tatsächlich als bad markiert (Antenne Bayern Kino Hits - gibt keinen Pieps von sich.) Aber natürlich nicht alle. Könnte allenfalls sein, daß ich versehentlich alle markiert hatte, als ich vermeintlich nur den einen editiert habe. Halte ich aber für eher unwahrscheinlich.

Außerdem hatte ich aufgrund der Login-Probleme - bevor ich wußte, daß gerade 434 herausgekommen und zeitgleich am Server herumgetweakt worden war;-)- zuerst an meiner settings.ini herumgespielt und dabei möglicherweise eine falsche "ID" im [Settings]-Abschnitt eingetragen.

Aus irgend welchen Gründen hatte ich dann plötzlich zwei verschiedene IDs in den verschiedenen Kopien der settings.ini vor und nach den beiden Build-Wechseln 414->433->434. Ich wußte dann nicht mehr, welche ID zu welchem Build gehört hat, und das Login hatte gestern mit beiden IDs nicht geklappt. Ich habe mich dann einfach auf eine der beiden IDs festgelegt, die ich seither nicht mehr geändert habe. Und seit dem Wechsel auf 434 hat dann ja auch alles gefunzt - bis auf die falschen "bad for recording"-Bits.

That's all.
Back to the roots! Back to Windows 2000!

Whatever you do, it'll be wrong, anyway. - Daddy is tired. Dad tired.
 
alex
2459 Beiträge
schrieb am 21.12.12 um 05:15 Uhrzuletzt bearbeitet von alex am 21.12.12 um 06:33 Uhr
Link zu diesem Post
Erstmal: Danke für den ausführlichen Bericht.

Das hört sich komisch an - die Datenbank sagt, dass du für einige Streams Daten gesetzt hast, aber "Aufnahme okay" ist überall auf "ja". An den Streams selber steht es auch so. Reproduzieren kann ich es nicht, aber nach einem Refresh der Stream-Liste sollte das für jeden User, egal was er wo gesetzt hat, gleich aussehen, was "Aufnahme okay" angeht.

Könntest du mir einmal dein streamWriter-Profil per Mail zuschicken? Ich teste es dann mal hier mit der Build 434, könnte der einfachste Weg zu einer Lösung sein.

(Profil exportieren siehe hier den zweiten Punkt von unten, Mailadresse siehe Menüpunkt "über" auf dieser Webseite.)
LG/Best regards, Alex

"Journalism is printing what someone else does not want printed. Everything else is public relations."
- George Orwell

D1734FA178BF7D5AE50CB1AD54442494